XAMPP is currently only availably as 32 bit application. Please use a 32 bit compatibility library for your system.

Posted by

Error:- XAMPP is currently only availably as 32 bit application. Please use a 32 bit compatibility library for your system.

One important thing i want to tell you that when you get this error XAMPP is currently only availably as 32 bit application. Please use a 32 bit compatibility library for your system. Then don’t think that you have any xampp issue or you xampp is 32 bit application. Its a very important thing to remember that you need to check your php error log and there you will get the actual error.

Below is the command to check the actual php error:-

Step 1 :- Go to your /opt/lampp directory
Step 2 :- find the directory logs.
Step 3 :- run the command to enter in /opt/lampp/logs
Step 4 :- "more php_error_log" run this command to fing the log of any php error.

So I got this error in my case.

PHP Fatal error:  Directive 'track_errors' is no longer available in PHP in Unknown on line 0

Solution for this:-

This warning was something I recently encountered when using php –version. My php.ini was found to be many years old, although the other php* files were just a few weeks old, when I searched in /usr/local/etc. The error notice was resolved by me by

Step 1:- Run below command.

sudo mv php.ini php.ini.old

Step 2 :- Follow the steps:

sudo cp php.ini-development php.ini

Step 3 :- Now go to your php.ini file which is located in the directory /opt/lampp/etc.

Step 4 :- Open php.ini file and see the code.

If 
track_errors = On
Then change On to off like this:
track_errors=Off

Issue Solved.

Leave a Reply

Your email address will not be published. Required fields are marked *

0
Would love your thoughts, please comment.x
()
x